Power outage at Baynes Sound
Incident Report for Ocean Networks Canada
Resolved
This incident has been resolved.
Posted Jan 09, 2025 - 18:29 UTC
Investigating
We have a suspected power outage at Baynes Sound Community Observatory.
Posted Jan 09, 2025 - 18:21 UTC
This incident affected: Community Observatories (Baynes Sound, BC).