Suspected power issue at China Creek.
Incident Report for Ocean Networks Canada
Resolved
This incident has been resolved.
Posted Apr 12, 2024 - 11:03 UTC
Investigating
We have a suspected power outage at China Creek Community Observatory
Posted Apr 12, 2024 - 11:01 UTC
This incident affected: Community Observatories (China Creek, BC).