Hartley Bay power outage suspected

Incident Report for Ocean Networks Canada

Resolved

This incident has been resolved.
Posted Jun 27, 2025 - 13:19 UTC

Investigating

An incident has occurred at Hartley Bay and we are investigating.
Posted Jun 24, 2025 - 21:36 UTC
This incident affected: Community Observatories (Hartley Bay, BC).