Power outage at Baynes Sound
Incident Report for Ocean Networks Canada
Resolved
This incident has been resolved.
Posted Nov 06, 2024 - 17:34 UTC
Investigating
We have a suspected power outage at Baynes Sound Community Observatory.
Posted Nov 06, 2024 - 17:12 UTC
This incident affected: Community Observatories (Baynes Sound, BC).