Suspected power issue at China Creek.
Incident Report for Ocean Networks Canada
Resolved
This incident has been resolved.
Posted Jan 08, 2025 - 05:24 UTC
Investigating
We have a suspected power outage at China Creek Community Observatory
Posted Jan 08, 2025 - 05:23 UTC
This incident affected: Community Observatories (China Creek, BC).