Issues at Cambridge Bay
Incident Report for Ocean Networks Canada
Resolved
This incident has been resolved.
Posted Jul 22, 2024 - 18:27 UTC
Investigating
Monitoring has indicated issues at Cambridge Bay. We are investigating.
Posted Jul 22, 2024 - 17:23 UTC
This incident affected: Community Observatories (Cambridge Bay, NU).